Performance Reads ‘Not Enabled’


When looking at the performance monitor under the column ‘Performance’, the message ‘Not Enabled’ is indicated instead of the typical message of ‘Excellent’, ‘Poor’, or ‘Critical’.  This simply means that the threshold for this agent is not enabled and needs to have the record inserted via the threshold table.

To correct this error, run the following statements located in the below script

— Get the Id of the Publication

DECLARE @PublicationID AS INT

SET @PublicationID = (SELECT [publication_id]

FROM [distribution].[dbo].[MSpublications]

WHERE publication = ‘Publication Name’

)

 

— Add the proper missing thresholds

INSERT INTO [distribution].[dbo].[MSpublicationthresholds]

([publication_id]

,[metric_id]

,[value]

,[shouldalert]

,[isenabled])

VALUES

(@PublicationID   — [publication_id]

,1

,80

,0

,1)

GO

 

INSERT INTO [distribution].[dbo].[MSpublicationthresholds]

([publication_id]

,[metric_id]

,[value]

,[shouldalert]

,[isenabled])

VALUES

(@PublicationID   — [publication_id]

,2

,30

,0
,1)
GO

Advertisements
This entry was posted in Replication. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s